Jump to content

Roxio the worst website experience ever


Recommended Posts

Sorry for this rant you regulars...

 

I'm a 46 year old, in the IT business.

 

I have been using the basic version of Roxio easy CD for a couple of years now and finally bought the full version at BestBuy yesterday. It's version 6.

 

I went to install it and it needed to uninstall the basic... but it won't. Plain and simple. Seems I don't have the original disk... who knows where it is... but without it, your screwed. WinXP can't delete it, nothing can... short of going into the registery.... I tried the suggestions from the online tech support... nothing works. Maybe if I can get a copy of Basic 6, then will be able to GET RID OF IT. It's like a virus...

 

Then there's this website... I went to get info, and you can't do that without a password. You can't ask a SINGLE question without a password. IT would not accept my email address to register... would not accept my alt address, saying it was already registered. I"VE NEVER REGISTERED HERE B4. Kept asking for a NON EXISTANT password... it's the WORST experience I"VE EVER had on a website.

 

Finally I signed up for a new email address at Yahoo just to be able to get in here...

 

All this will fall on deaf ears I know... ROxio could care less that their website is infurating to non-regulars. but I just had to rant anyway... just in case they might actually be listening.

 

CL

Link to comment
Share on other sites

Hello Clyde,

 

You posted your message in the "general chat, no Roxio stuff" forum, so it was moved here.

 

Roxio doesn't listen here. This site is populated by customers like me who help each other. I can't comment on how easy the Roxio/Sonic site is because I haven't been there for a long while. However I just hopped over there to their front page, clicked on SUPPORT, and found myself facing a lot of FAQs and support articles without having to log in anywhere.

 

Can I help you with your problem?

 

I understand that you've been using version 6 Basic for years, and then went and bought the version 6 retail version. Now you need to uninstall Basic, but you can't because you've lost your Basic CD. Is that a fair summary of the problem?

 

I would suggest a double-pronged method of uninstalling 6 Basic and banishing the fragments. The first part should do a quick but effective cleanout, and the second part will remove any installer fragments from your system. This should leave you a pristine system where you can install your retail version without let or hindrance. Here's how:

 

1) go to the top of this forum, and have a look at the pinned message which was posted there for your information. In that message you'll see a reference to the Roxio uninstaller, ROXIZAP. Click on the link given there, and download that utility.

 

Run Roxizap, and it will immediately remove all the parts of this Creator which might prevent a reinstallation. You may go around the hard drive and manually delete any Roxio directories which escaped the flamethrower, but you shouldn't find much left after Roxizap.

 

2) Go to HERE and get the Windows Installer Cleanup Utility from Microsoft.

 

Read that MS page thoroughly, and use the Cleanup Utility to remove any installer fragments left behind by version 6 Basic.

 

-Your drive should now be very clean with respect to the old version, and installing the new one should be a snip.

 

Please let us know here, how you get on.

Link to comment
Share on other sites

Cool. Roxio Zap did the trick. I was then able to install the full version 6 without any hitches.

 

Now to figure out why the basic version worked fine with my Plextor PX-708a but the full version 6 won't recognise it, D'OH. more research...

 

Thanks for the help = )

 

CL

Link to comment
Share on other sites

That's simple.

 

Plextor modified the program to support their burner.

 

Plextor may give you the necessary bit of modification needed to get it going again. Try contacting them.

 

As to the password problem - it is fortunate I have this as a "favorite" with the password alread entered, because otherwise I don't seem to be able to get in either.

 

Lynn

Link to comment
Share on other sites

Sorry for this rant you regulars...

 

I'm a 46 year old, in the IT business.

 

I have been using the basic version of Roxio easy CD for a couple of years now and finally bought the full version at BestBuy yesterday. It's version 6.

 

I went to install it and it needed to uninstall the basic... but it won't. Plain and simple. Seems I don't have the original disk... who knows where it is... but without it, your screwed. WinXP can't delete it, nothing can... short of going into the registery.... I tried the suggestions from the online tech support... nothing works. Maybe if I can get a copy of Basic 6, then will be able to GET RID OF IT. It's like a virus...

 

Then there's this website... I went to get info, and you can't do that without a password. You can't ask a SINGLE question without a password. IT would not accept my email address to register... would not accept my alt address, saying it was already registered. I"VE NEVER REGISTERED HERE B4. Kept asking for a NON EXISTANT password... it's the WORST experience I"VE EVER had on a website.

 

Finally I signed up for a new email address at Yahoo just to be able to get in here...

 

All this will fall on deaf ears I know... ROxio could care less that their website is infurating to non-regulars. but I just had to rant anyway... just in case they might actually be listening.

 

CL

 

I must agree with you. The experience i had with the site was the most frustrating ever. I didnt want to pay for a service call so i tried using the internet chat with a service rep. No help what so ever. I thought i would try calling the 905 number and found out it was in Canada an international call so i scrapped that . I figured i would give this a try before i tried to return EMC 8 to the reseller,

Link to comment
Share on other sites

I must agree with you. The experience i had with the site was the most frustrating ever. I didnt want to pay for a service call so i tried using the internet chat with a service rep. No help what so ever. I thought i would try calling the 905 number and found out it was in Canada an international call so i scrapped that . I figured i would give this a try before i tried to return EMC 8 to the reseller,

 

 

mpp39

 

 

It would be nice if you started a separate thread with your problem (whatever it is).

 

This way we dont get all screwed up.

 

Thanks (another fellow user).

Link to comment
Share on other sites

BTW Clydelover, Thanks for posting back and thanking another very dedicated and knowledgeable user. That's always a nice GESTURE when we get back a post indicating if the suggestions were helpful or not.

 

 

 

Hey KUDOS Brendon. Good show mate :)

 

Frank....

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...