Jump to content
  • 0
Sign in to follow this  
knight2001dts

Creating Bd From Bunch Of Dvd Vob Files = Randomly Skipping A/v? Help Please?!?

Question

Hi!

 

I am currently using a mates MAC computer to play with Toast 11 to try and make a Blu-Ray disc with a heap of SD quality DVD .VOB files.

 

I have worked out how to do exactly what I need to do, and can create a menu free image that burns onto BD-R and plays in a BluRay player, but the problem is that the resulting disc (and image) has random a/v skips....(effect is like a quick jump in time of both audio and video without pixelation).

 

At first I thought it might be the BD media I was using, but I checked the HDD image file I saved first, and it also was jumping.

 

I am using short NTSC 29.97 format clips with LPCM audio track....yet to check PAL 25.00 to see if result is the same (NOTE - It isn't a similar effect to a video frame-rate conversion stutter.....it is a real JUMP of a second maybe)

 

The source VOB files are 100% smooth video and audio, and I am NOT re-encoding (using custom option and have selected to never re-encode) and quite frankly don't want to re-encode either.

 

 

I absolutely love the program and the fact that it is sooooo easy to use, but cant get the clips to play smooth on the resulting encode.

 

I have tried to create the disc and image from scratch several times, and it always does the a/v skip at the same point.

 

 

Anyone else having this problem? or got any suggestions?

 

 

 

P.S. TOAST doesn't report any errors when the image is being generated.

 

 

CHEERS!!

 

Knight.

Edited by knight2001dts

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Interesting. Toast never has liked VOBs very much. I suspect yours have some time code breaks which may be causing the skips after Toast multiplexes the videos. It may be necessary to first use MPEG Streamclip to remove time code breaks and then save as .mpg files for use in Toast. This doesn't involve any re-encoding.

 

If your VOBs are in their VIDEO_TS folder you also can extract the videos using the Toast Media Browser rather than dragging the VOBs into the Toast window. This is done by placing a VIDEO_TS folder on the desktop or in the movies folder and then choosing DVD under the Media Browser's video tab.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply tsantee....

 

My thinking was along those lines also, but I was having trouble finding a program that would strip the VOB of all but the elementary streams I want.

 

Thankyou so much for referring me to MPEG streamclip - it is a fantastic little application.

 

Well, I ran the .vob (they are seperate .vob files and not part of a VIDEO_TS folder) through MPEG Streamclip and it spat out a nice shiny WORKING MPEG 2 clip minus the .vob nasties without re-encoding......exactly what I was after.

 

Unfortunately though, TOAST still produces the same result......with a/v skipping in exactly the same spots as before.

 

I have tried output as SD DVD and output as HD DVD and BluRay.....same result.

 

I thought it may be a problem with the LPCM audio source, so I also tried converting the audio to Dolby Digital with TOAST, but again, I get the same a/v skipping in the same spots.

 

 

I have checked the video / audio of the clip from within TOAST as well, and it plays perfectly fine BEFORE conversion to DVD/BluRay

 

I'm open to other suggestions.......and finding the situation extremely frustrating, but also enjoying the challenge.....

 

CHEERS!

 

Knight

Edited by knight2001dts

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply tsantee....

 

My thinking was along those lines also, but I was having trouble finding a program that would strip the VOB of all but the elementary streams I want.

 

Thankyou so much for referring me to MPEG streamclip - it is a fantastic little application.

 

Well, I ran the .vob (they are seperate .vob files and not part of a VIDEO_TS folder) through MPEG Streamclip and it spat out a nice shiny WORKING MPEG 2 clip minus the .vob nasties without re-encoding......exactly what I was after.

 

Unfortunately though, TOAST still produces the same result......with a/v skipping in exactly the same spots as before.

 

I have tried output as SD DVD and output as HD DVD and BluRay.....same result.

 

I thought it may be a problem with the LPCM audio source, so I also tried converting the audio to Dolby Digital with TOAST, but again, I get the same a/v skipping in the same spots.

 

 

I have checked the video / audio of the clip from within TOAST as well, and it plays perfectly fine BEFORE conversion to DVD/BluRay

 

I'm open to other suggestions.......and finding the situation extremely frustrating, but also enjoying the challenge.....

 

CHEERS!

 

Knight

Drat. Did you do the Fix Timecode breaks command in MPEG Streamclip's Edit menu?

Share this post


Link to post
Share on other sites
  • 0

Yes....I tried the timecode fix, but it also didn't help.

 

I have narrowed it down to the LPCM audio though....maybe.....

 

I used MPEG streamclip to convert the VOB into mp4 with AAC audio........and the output from TOASt is glitch free! It worked....

 

BUT

 

I dont want to convert the video, and really want to keep the LPCM audio.

 

Is this a codec issue maybe? (not too familiar with apple and codecs - I know windows is a PITA when it comes to codecs)

 

does Toast have an issue with LPCM/PCM in general?

 

I might try to convert the audio only to FLAC or something else, but what would you recommend to try to keep the audio lossless and also compatible with TOAST?

 

CHEERS!

 

Knight.

Share this post


Link to post
Share on other sites
  • 0

OK......

 

problem solved.

 

It was the LPCM audio that was upsetting everything.

 

 

I demuxed the VOB streams using DVD Decrypter and first saved audio as LPCM and then did it again after selecting the "save LPCM as WAV" option under the stream processing submenu.

 

I got my 3 streams......

.M2V video file

.PCM audio file

.WAV audio file

 

First, I remuxed the .M2V and the .PCM using tsmuxer and output a .m2ts file

 

Secondly, I remuxed the .M2V and the .WAV file and output a second .m2ts file

 

 

I fed each in turn into TOAST and output a BD image to the HDD using the NEVER re-encode settings and PCM audio selected

 

*** side question.....if I select NEVER re-encode, is this for BOTH audio and video? or just video?? I have a feeling it might be both?? **

 

The resulting output was:

 

the first stream once again FAILED - skipping in all the same spots as i expected

 

the second stream WORKED!!! PROBLEM SOLVED!!

 

This has added a lot more work to the project, but at least I know that it is a problem with TOAST and LPCM audio. When using .WAV uncompressed instead, it works just fine.

 

Now ROXIO, any chance of a bug fix??? ;P

 

I'm happy to provide the offending PCM audio track if anyone wants to try a fix....

 

 

Now, does anyone know of a nice, easy to use batch VOB demux tool that allows remuxed file output in VOB and M2TS file format?

 

Thanks again for the suggestions tsantee.

 

 

CHEERS!!!

 

Knight.

Share this post


Link to post
Share on other sites
  • 0

OK......

 

problem solved.

 

*** side question.....if I select NEVER re-encode, is this for BOTH audio and video? or just video?? I have a feeling it might be both?? **

Toast always encodes the audio when it encodes the video stream. It can't do audio only and it can't encode only the video. The only exception is if the audio stream is mpeg then Toast leaves it alone because it doesn't decode mpeg audio.

 

Now ROXIO, any chance of a bug fix???

You can send Roxio feedback using the Feedback link in Toast Help.

 

Now, does anyone know of a nice, easy to use batch VOB demux tool that allows remuxed file output in VOB and M2TS file format?

You might take a look at MPEG2Works. I don't know if it has a batch mode.

Share this post


Link to post
Share on other sites
  • 0

Toast always encodes the audio when it encodes the video stream. It can't do audio only and it can't encode only the video. The only exception is if the audio stream is mpeg then Toast leaves it alone because it doesn't decode mpeg audio.

 

 

You can send Roxio feedback using the Feedback link in Toast Help.

 

 

You might take a look at MPEG2Works. I don't know if it has a batch mode.

Share this post


Link to post
Share on other sites
  • 0

Could you also have used StreamClip to convert to MP2 with MP2 audio option... which I believe would convert the audio but leave the video untouched...

Share this post


Link to post
Share on other sites
  • 0

I too have problems with skips when burning DVDs with individual vob files (such as extracted music videos) that are not in a VIDEO_TS folder. My solution has been to use MPEGStreamclip to convert the vobs to dv files - which take up a lot of space - and then drag them into Toast and burn a DVD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×