Jump to content
  • Who's Online   0 Members, 0 Anonymous, 14 Guests (See full list)

    There are no registered users currently online

  • 0
billy_iv

Creator 2012 Will Not Open Hangs When Opening

Question

I just installed Creator 2012 and now it will not open. It hangs on the opening screen and gets stuck on the following step...installing roxio central search support. It will not go past that point. I do not have anti virus installed and I have already run the repair option. This was downloaded from amazon so I do not have a CD. I have uninstalled and re installed and still have the same problem. I am running windows XP. Any thoughts or ideas or have I just spent $37 in stupid tax??? Thanks!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

An Amazon download from their site or from someone else selling it on their site? Please post a link. I would just return it as soon as possible and get your money back. I just moved your post to the right part of the forum. Look at the pinned posts at the top of this section of the forum for some hints.

 

Does you computer meet the minimum requirements for this program? Did you update/prepare your computer before installing the program (Link)?

 

No anti-virus at ALL? Not even Windows Security Essentials? Personally I would not download any program wihout running it through some anti-virus check. Good luck.

Edited by sknis

Share this post


Link to post
Share on other sites
  • 0

I tried all those hints listed above. It was a download from Amazon, not a re-seller. I did do the "preparations" after I uninstalled the program. I then did the re-install and it still hangs in the same place. I emailed Amazon last night and they have already processed a refund for me, even though they did not have to. I used a previous version of roxio before and it worked like a charm. It seems that this version is pretty buggy, especially if you have to prep your system before install and then repair the install before you even run it the first time. Gonna look at other options now. Thanks for your help.

 

BTW, I have anti virus on it, AVG, but removed it for the 4th install attempt HOPING that it might work. I have since re-installed it.

 

Here is the link http://www.amazon.co...rd_i=B005CELI0U

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×