Jump to content
  • 0
Tim Hewett

Toast 9 - Can't Load Video Into Toast Video Player For Editing (Mountain Lion)

Question

Since around the time of the MacOS 10.8.1 or 10.8.2 update, every now and again my Toast 9 enters a state such that it refuses to load a video into Toast Video Player for editing (i.e. by clicking the Edit button in the dialog box for the clip). Toast Video Player starts as an application but doesn't open the video.

 

Also sometimes Toast Video Player opens and loads the clip but when the cut points have been set and saved, Toast ignores them.

 

The only way I have found to resolve the problem is a complete reboot of the entire Mac. Stopping and restarting Toast and the video player doesn't solved the problem.

 

Loading video directly into Toast Video Player, e.g. by drag/drop from the Finder, works fine, the problem seems to be in the intercommunication between Toast and Toast Video Player.

 

I have been using Toast 9 for years without this problem, even after initially updating to Mountain Lion, it has only started to happen recently.

 

Any hints as to a solution gratefully received.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Sorry, but I have no suggestions. You already are having more success with it than I did when I was using that version. Roxio changed this in Toast 11. Instead of Toast Video Player there is Roxio Video Player which isn't from ElGato like the one you have. The new one is a player only. The editing is done in the Toast application itself. If the one you're using becomes too frustrating I suggest giving the one in Toast 11 a try.

Share this post


Link to post
Share on other sites
  • 0

Are you aware of how Toast and Toast Video Player communicate with each other? Perhaps I can delete stray files or such like and get my (already paid for and not prepared to pay for again!) functionality.

Share this post


Link to post
Share on other sites
  • 0

Are you aware of how Toast and Toast Video Player communicate with each other? Perhaps I can delete stray files or such like and get my (already paid for and not prepared to pay for again!) functionality.

The problem I had with Toast Video Player is that it would sometimes freeze when the source was a HD video. It worked fine for me with SD videos. That happened when I used it with my MacBook Pro but didn't happen with my newer iMac. It seems to me that the capability of the Mac's graphics card affects the ability of Toast Video Player with HD sources. On the iMac I encountered problems with it ignoring editing marks. It would see an editing mark near the middle of the video as being the end of the video so I didn't get all the video in my end product. It was random where the end would occur but was a consistent problem. As a result I quit using the editor. It had worked early on so I think the problem appeared as a result of system updates.

 

What I resorted to doing was making a Blu-ray disc image of the unedited video and then editing its .m2ts file with MPEG Streamclip (which takes some effort). My source videos were TiVo transfers so they needed to be clear of the TiVo "wrapper" in order for them to work with Streamclip. I have a PC laptop (I need it when working with one client) so I purchased a low-cost editing application for it that works although it isn't as easy to use as it should be.

 

I don't know any fix for this. I don't know for certain what was the last OS version in which the editor in Toast Video Player worked. I don't believe the problem has anything to do with corrupted files or preferences. The version in Toast 10 and Popcorn 4 has the same issues.

Edited by tsantee

Share this post


Link to post
Share on other sites
  • 0

Well... quitting and restarting either (or both) apps doesn't fix it, nor does re-installing from the 9.07a update DMG, but logging out and back in again returns normal operation. Very annoying but at least now I know it isn't necessary to go so far as a reboot. But what can logging out and back in again achieve that quitting the app and starting it again doesn't?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×