Jump to content
  • 0

.m2Ts Audio Not Showing Up In Sony Vegas Pro 11


WinningTeam
 Share

Question

Ok well I just recently purchased a Roxio Game Capture HD to replace my HDPVR ive had for over 2 years. I make gaming videos for youtube and figured it would be a good upgrade and allow me to use hdmi and get a bit better quality. The problem I am running into is that I edit my videos in Sony Vegas and for some reason audio is not showing up in the time line in Sony Vegas. The video shows up and plays fine with no lag but there is no audio clip underneath it and vegas is not seeing it as having audio at all. The weird thing is, the game capture hd only records in .m2ts file format and that's the same file format my hdpvr uses. When i import a clip from my hdpvr of my xbox 360 gameplay it shows up fine with the audio and everything but the audio doesn't show up for the game capture hd's files. The werid thing is, i know the device is recording the audio because i can play the clip with windows media player and I can hear it. Now i can convert the file with the videowave editing software that comes with the game capture hd and the audio shows up in sony vegas if it is coverted to an avi file but the quality isnt as good as the original recording. I've been trying to fix this for the last 2 hours by trying different fixes like re installing the roxio software, changing from hdmi to component, installing new video codecs, and messing with the settings of the recording software and I have found nothing that fixes my problem. If you know of any fixes for this please let me know because I really want to love this capture card but having this audio problem is really annoying. Thanks for your time and have a nice day!

  • Like 1
Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

 

i read through it and basically it said Im not going to be able to use the original file in Vegas unless i render it in video wave first... this stinks... Got any good render settings for videowave so that I keep the best quality possible? Everytime i tried to render a clip in it and put it in vegas it became a little grey and not as colorful.

Link to comment
Share on other sites

  • 0

i read through it and basically it said Im not going to be able to use the original file in Vegas unless i render it in video wave first... this stinks... Got any good render settings for videowave so that I keep the best quality possible? Everytime i tried to render a clip in it and put it in vegas it became a little grey and not as colorful.

 

that makes not much sense on "grey and not as colorful" i render my clips

try windows media video 9 1920x1080 VBR if you have recorded with the HDMI in 1080P

Link to comment
Share on other sites

  • 0

I do ALL of my editing and 99.9% of my burning with Roxio...

 

The ONLY reason I do anything in Vegas is to have a 'Play All' button in the menus of my AVCHD & BD Projects.

 

I understand the challenge of learning a new product but if this is what is needed, that that is what you have to do ;)

 

I hope to play with this in the future but not at the moment...

Link to comment
Share on other sites

  • 0

While I find this kind of thing unbelieveable in this day and age I don't actually know who to blame for the problem so let me just detail a nice free, safe and easy way to resolve this issue.

 

Download VLC media player from the videolan website, http://www.videolan.org/

Once you have it installed open VLC and choose Media, Convert/Save.

In the File Selection window click Add and browse to your m2ts file created using Roxio capture software

Then click the Convert/Save button at the bottom of the window.

In the Destination section click browse and the create a file called output.mp3 (or whatever you like).

In the Settings section drop down the profile selection tool and choose Audio - MP3.

Click Start.

 

This will generate an MP3 file that you can then load into Sony Vegas as a separate audio track.

 

You can change the quality of the MP3 file by editing the profile using the Edit Selected Profile button.

 

I hope that helps everyone.

 

Adrian

Link to comment
Share on other sites

  • 0

Good export options:

If it's one single clip, use Same as Original quality. It looks very good. If not, then export in AVCHD (Or whatever it's called, sorry, I'm not too good with this stuff ;) ) in the quality you recorded in (So for 720P it'd be 1080x720) and export in 60fps if you recorded in 59fps, and 30 if you recorded in 29.97 fps. Hope this helped!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...