Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

Capture Application Doesn't Load


AustinStanley
 Share

Question

Hey guys.

 

I've uninstalled, reinstalled, "repaired", everything I can think of. Basically. I load up the Roxio Program, it gives me the two options of EDIT and CAPTURE. When I click CAPTURE it takes me to the screen shot included and doesn't do anything else from that.

 

I'd really like to use the capture card for what I bought it for. Any and all suggestions will be mighty helpful. Thanks!

post-107175-0-44329200-1350718669_thumb.jpg

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Try the Repair again, only do it this way...

 

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

With the device plugged in, (software not running), open the Device Manager and Disable the device!

 

Remove the Capture Device and place it in another room!

 

Now insert your Roxio Disc (download version - run Install)

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

When the Repair competes, turn your AV & Firewall back on and reboot.

 

Check for updates when you start the program.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...