Jump to content
  • Who's Online   0 Members, 0 Anonymous, 3 Guests (See full list)

    • There are no registered users currently online
  • 0

Easy Vhs To Dvd 3 Plus Hangs



Hi there,


I purchased Easy VHS to DVD 3 Plus a few days ago, and I'm terribly frustrated with it so far, as I have yet to be able to capture a single video. Why, you ask? I have yet to be able to get the capture software to start. I've scoured the forums and the web for answers, but can't seem to locate any definitive answers.


Here's what I've done so far:


1) Installed Easy VHS from the installation disc

2) Connected the capture device

3) Tried to start up the Easy VHS app


From here, the splash screen hangs indefinitely. Interestingly, I can't even kill the process with the task manager when that happens. So, it's stuffed up pretty good.


Since then, I've tried the following (with reboots between each step since the process hangs):


1) Repairing the installation using the installation disc. No effect.

2) Looked for updates on the Roxio site. There are none posted.

3) Applied any outstanding Windows Updates,

4) Tried running in various compatibility modes, most notably Win XP SP2 and Win XP SP3. No luck.

5) Tried running as an administrator. No change.

6) Posted a support ticket on the Roxio/Corel site. The "technician" basically ignored the details of my post, asking if I had "tried installing the software properly" if I had been "sure to plug the device in". I immediately responded that I had, and have not heard anything since.


I've tried this on two completely different Win 7 x64 machines, one with a Athlon Phenom II X4 under the hood and one with an Intel i7. Each machine has 8GB of RAM and 100 GB of HDD free.


I was also able to borrow a friend's XP machine and tried all of the aforementioned steps on that machine as well. On that XP machine, I can actually get the software to start, but after capturing video for a few minutes, I get the dreaded BSoD. This has happened each and every time, but after varying lengths of recording.


I'm BEYOND frustrated with this product. The whole reason I bought this product is because my old capture device doesn't support Windows 7 compatibility. Unfortunately, it appears that this product doesn't either. Does anyone have any advice for what to try next? Any help would be appreciated.


Thanks in advance,



PS - I should also note that after repeated failures with the boxed software, I also attempted to capture video using Windows Movie Maker. WMM can't connect to the device for some reason. I then tried VirtualDub. The app hangs when I select my capture device. Finally, I tried VLC. I have been able to capture video with VLC. So, at least that demonstrates that the device is working properly on some level. However, the results with VLC have been sub-par because any of the codecs that seem to work with VLC don't seem to play through Windows Media Player (MP4 [H264 + MP3], for example).

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

As I've tried this on a number of machines, I've got a lot of log files. Here's the most recent installation I did from scratch (after a complete uninstall) on my main machine Win 7 x64 machine. I've also included the attempt to repair in the logs. Let me know if you need anything more, and thanks in advance for looking into this!

Roxio Log Files.zip

Link to comment
Share on other sites

Ok, so first of all... msxml4 sp 3 was not installed, so I installed that. Of course, that doesn't explain why the Roxio installer wouldn't be able to detect and/or correct that issue, but either way... it is installed now.


However, the DirectX 9.0c thing is throwing me for a loop. According the this article, installing DirectX 9.0c directly is not an option for Win7:




On Win7 machines, DirectX 11 is the only option. Of course, DX11 allegedly includes all DX10 libraries, which in turn includes all DX9.0c libraries. I definitely have DX11 installed. Just for kicks, I tried to install DirectX 9.0c anyway, and the installer finished in like 2 milliseconds and said, "Installation complete."


In any case... After making all of these updates (and a few restarts), I still have the same issue of things hanging on the splash screen. So, I tried ANOTHER complete uninstall and reinstall, and still got the same results. I've attached a copy of the most recent set of log files if that helps at all.


Any other ideas? Thanks in advance.

Roxio Log Files.zip

Link to comment
Share on other sites

Strange this same thing happened on three different computers!


Download and install, DirectX End-User Runtime Web Installer Version: 9.29.1974 Date published: 4/18/2011


Here, http://www.microsoft...ails.aspx?id=35


First right clicking the .exe file and installing/running in any compatibility mode is the wrong thing to do.


Make sure the PC meets this, Minimum System Requirements: Microsoft® Windows 7 Home Premium, Windows Vista® Home Basic (SP1), Windows® XP (SP3 for 32-bit, SP2 for 64-bit)


You need to install as administrator or be in a account with administrator privileges.


Follow these instructions to a 'T' installing or running a repair.




For a uninstall reinstall some folks recommend the Revo Uninstaller Freeware, ran in moderate mode (be careful) here, http://www.revounins...e_download.html


Let us know if anything changes or fixes your problems?

Link to comment
Share on other sites

While I agree that it seems pretty strange happening on three different machines like that, it appears to be a somewhat common problem based on other forum posts, product reviews, and such. So, maybe it's not that strange after all.


A few updates:


1) After my last post to you all, I did a little more work on the DirectX side of things. I had actually found the exact same link you posted and tried installing from there. The install went smoothly, but nothing changed when running the capture app. I even tried a complete uninstall of the Roxio software with Revo, then a complete reinstall after the DirectX installation, but no luck.


2) My machine definitely meets all of the aforementioned requirements. Also, when I said that I tried to run in various compatibility modes, that was [a] only after all other approaches failed and only when running the capture app. Normally, I shy away from compatibility modes as much as possible. Win 7 had just suggested it after one of the app launches failed, so I figured it was worth a try that one time. I've since gone back to just running normally. My user is an admin on the machine(s) in question, and I've also tried "Run as Administrator...". Same result either way.


3) Strangely enough, I also noticed that on at least one of my machines, a number of things stopped working after the Roxio installation. Specifically, Spotify hung when I tried to play any music. Same thing with a few games. I also tried multiple restarts after each failure, just to make sure the installation process and/or a failed launch of the app wasn't gumming anything up. Of course, when I uninstalled the Roxio stuff and restarted, Spotify started working again, as did the games that were hanging. Shrug.


Unfortunately, its starting to look like this has basically been a complete waste of time and money. Even when I was able to get the software running (on that XP machine I borrowed), I BSoD'ed every time I captured a video. So, this VHS-capturing adventure has pretty much been an epic fail.


Thanks so much for all of your help thus far, everyone. If I find anything out, I'll be sure to update this post for anyone else facing the same issues. I'm running out of time before the holidays to get this project done, so if nothing else, I might pursue another piece of software with the same device. Sucks that I had to pay for the Roxio software if it's unusable for me, but at least I might be able to salvage something out of all this before the holidays.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...