Jump to content
  • 0

Installation Of Nxt Pro Failed. Rolled Back. Error 1603.


opsman
 Share

Question

I downloaded the NXT Pro install online. Placed into a folder and then ran the RoxioCreatorNXTPro_LC36AXD0R14.exe executable.

 

It seemed to install up to the point of the NXT Pro program and then failed, rolled back all installs.

 

The issue seems to hit during the install of Roxio NXT Pro and may be related to EMC_140 (not sure what that is at this point).

 

My PC is fairly standard. Intel i7 processor running Windows 7 Ultimate 64 bit, ASUS mobo, Nvidia GeForce GTX 560Ti video. All updated with latest drivers as well as Windows updates. I even uninstalled the antivirus. Media Player is version 12. Tried disabling all startup programs using msconfig as suggested in knowledgebase article.

 

Not sure why the logs are complaining about having DirectX version 9.0c installed. According to dxdiag, current DirectX version is 11.0.

 

The Roxio Setup log seems to hit a snag at this point:

12/23/12 10:46:42 - Updating install progress: 8 / 12, Installing Roxio Creator NXT Pro

12/23/12 10:46:42 - Executing setup action: InstallActions.EMC_140.Install

12/23/12 10:46:42 - Action InstallActions.EMC_140.Install return code: 0

12/23/12 10:46:42 - Action InstallActions.EMC_140.Install is Sync

12/23/12 10:46:42 - Action InstallActions.EMC_140.Install has SyncHandle not equal NULL.

12/23/12 10:46:42 - Attempting to determine the version of MSI.DLL

12/23/12 10:46:42 - Installing Package: 'd:\Users\office\AppData\Local\Temp\RoxioCreatorNXTPRO_LC36AXD0R14\EMC_140\Roxio Creator NXT Pro.msi', with Properties: 'REBOOT=ReallySuppress TRANSFORMS="d:\Users\office\AppData\Local\Temp\RoxioCreatorNXTPRO_LC36AXD0R14\EMC_140\1033.mst" INSTALLERDIR="d:\Users\office\AppData\Local\Temp\VIES5703\" ARPSYSTEMCOMPONENT=1 ROX_KEYTEXT=y3N0HiwTuXcDrGSkSr79PhtEjm0Juzof

DESKTOPICON=never QUICKLAUNCHICON=never INSTALLDIR="D:\Program Files (x86)\Roxio Creator NXT\" MPI_SUITE_ID={CC915001-1639-4D1B-B0A1-A7AC70C99179} MPI_EULA_ACCEPTED=1 ADDLOCAL=ALL'

12/23/12 10:47:08 - Execution of Windows Installer package 'd:\Users\office\AppData\Local\Temp\RoxioCreatorNXTPRO_LC36AXD0R14\EMC_140\Roxio Creator NXT Pro.msi' finished with exit code = 1603

12/23/12 10:47:08 - Updating install progress: 9 / 12, (null)

12/23/12 10:47:08 - Action InstallActions.EMC_140.Install failed with exit code 1603.

12/23/12 10:47:08 - Installation failed with error code 1603

12/23/12 10:47:08 - Rolling back installation

 

Taking a look at the EMC_140 log, I see a couple of things that are of interest, but not sure if they are related.

MSI (s) (D0:24) [10:46:42:785]: TRANSFORM: 'PatchPackage' table is missing or empty. No pre-transform fixup necessary.

MSI (s) (D0:24) [10:46:42:785]: TRANSFORM: Applying regular transform to database.

Property(S): RX_DX_NEEDS_UPDATE = You need to update your version of DirectX to version 9.0c.

Property(S): ISSCRIPT_VERSION_MISSING = The InstallScript engine is missing from this machine. If available, please run ISScript.msi

ROXIO_SETUP.txt

EMC_140_Install_Excerpt.txt

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

OK. Sorry about that, but the log files are so large they are over the 5MB limit. So... here we go. I had to break these apart into separate pieces because the log files were still a bit too large.

EMC_140_Uninstall.zip

RBVIRTUALFOLDER64_0210_Uninstall.zip

ROXIO_BURN_0210_Uninstall.zip

ROXIO_SETUP.txt

VIRTUALDRIVE64_140_Uninstall.zip

WINDVD_Uninstall.zip

Link to comment
Share on other sites

  • 0

Just checked the Microsoft KB: http://support.microsoft.com/kb/834484

 

When I run, subst, at the command prompt, nothing returns so I am thinking the substitute drive idea doesn't apply. The installation directory is not the system directory - it is D:\Program Files (x86)\Roxio Creator NXT\.

 

The drive is not encrypted (nor the folder). And, the system account appears to have all permissions.

 

I have also removed all temporary files from the temp folder and ran the install program as administrator.

Edited by opsman
Link to comment
Share on other sites

  • 0
the installation directory is not the system directory - it is D:\Program Files (x86)\Roxio Creator NXT\.

 

That could be the problem. It still writes files to C Drive even if you install it to D drive.

 

Are you running a SSD Drive on C Drive?

 

Have a read through this 'Microsoft error 1603'

 

http://support.microsoft.com/kb/834484

Edited by cdanteek
Link to comment
Share on other sites

  • 0

Yep. Definitely using SSD drive which is the C. Your everyday ole' magnetic platter SATA 6G/s for the D.

 

I am not sure if the Windows article addresses that issue. Nothing is stopping the install from using the C. Plus, according the Microsoft definition of "substitute" drive this configuration where the drives are mounted (normally) isn't a substitute. But, maybe I am wrong. It clearly isn't installing. I know that.

 

The drives act as a normal c drive and normal d drive. I have yet to have a problem installing any other program -- but I know that may not mean much either.

Link to comment
Share on other sites

  • 0

I have the same problem and need help too; however I think I can help others if you try what I outlined below

Install One at a time and fix your permissions as needed. I will not be back to check this post [yours or mine I

seem to have jury duty for the next 3 weeks]

 

OS Name Microsoft Windows 7 Home Premium x64

Version 6.1.7601 Service Pack 1 Build 7601

Other OS Description Not Available

OS Manufacturer Microsoft Corporation

System Name TOSHIBA

System Manufacturer TOSHIBA

System Model Satellite A505D

System Type x64-based PC

Processor AMD Turion II Ultra Dual-Core Mobile M620, 2500 Mhz, 2 Core(s), 2 Logical Processor(s)

BIOS Version/Date Insyde Corp. 1.00, 9/8/2009

SMBIOS Version 2.6

Windows Directory C:\windows

System Directory C:\windows\system32

Boot Device \Device\HarddiskVolume1

Hardware Abstraction Layer Version = "6.1.7601.17514"

Installed Physical Memory (RAM) 4.00 GB

Total Physical Memory 3.75 GB

Available Physical Memory 2.21 GB

Total Virtual Memory 9.36 GB

Available Virtual Memory 7.58 GB

Page File Space 5.62 GB

Page File C:\pagefile.sys

 

Did clean uninstall of 2011 which would not install this time)

then edited the registry to and used regserv to get a clean and defraged registry

Install of Roxio Failed

tried install without Back on Track still failed

tried install as administrator instead of just an administrator account Failed

Install Roxio NXT Failed Again

fixed registry key and windows directory permissions [take ownership and open full control]

cleaned up registry with regserv to remove all junk

Review of install logs showed many registry keys, directories and some files could not be opened

with access denied

One by one I took ownership as administrators then opened permissions full some I even gave everyone

Install Roxio Creator and Burn - failed again

install Roxio Creator only - Success

SUCCESS - CREATOR AND THE ASSOCOCIATED APPS ALL INSTALLED

if success you will see an install log but not an uninstall log and no zip file

Creator and all the apps work

Install Roxio Burn (selected modify and check it)

FAILS

BURN INSTALL WILL ROLLSBACK BUT NOT CREATOR AS HAPPENS WHEN YOU TRY TO INSTALL ALL AT ONCE

 

*************THIS IS WHERE I SEEM TO NEED HELP FROM SOMEONE***************

*************THIS IS THE FAIL POINT FOR BURN THEN DOES ROLLBACK - RIGHT AFTER UPDATE**************

 

install Roxio_Burn Fails

Property(S): SOURCEDIR = C:\temp\RoxioCreatorNXT_LC36AXD0R13\ROXIO_BURN_0210\

Property(S): SourcedirProduct = {A33E7B0C-B99C-4EC9-B702-8A328B161AF9}

Property(S): ProductToBeRegistered = 1

MSI (s) (C0:10) [15:00:42:174]: Note: 1: 1708

MSI (s) (C0:10) [15:00:42:174]: Note: 1: 2262 2: Error 3: -2147287038

MSI (s) (C0:10) [15:00:42:174]: Transforming table Error.

 

MSI (s) (C0:10) [15:00:42:174]: Note: 1: 2262 2: Error 3: -2147287038

MSI (s) (C0:10) [15:00:42:174]: Transforming table Error.

 

MSI (s) (C0:10) [15:00:42:174]: Product: Roxio Burn -- Installation operation failed.

 

MSI (s) (C0:10) [15:00:42:174]: Windows Installer installed the product. Product Name: Roxio Burn. Product

 

Version: 2.0. Product Language: 1033. Manufacturer: Roxio. Installation success or error status: 1603.

 

MSI (s) (C0:10) [15:00:42:174]: Attempting to delete file C:\windows\Installer\5708af.mst

MSI (s) (C0:10) [15:00:42:174]: Unable to delete the file. LastError = 32

MSI (s) (C0:10) [15:00:42:189]: Deferring clean up of packages/files, if any exist

MSI (s) (C0:10) [15:00:42:189]: Attempting to delete file C:\windows\Installer\5708af.mst

MSI (s) (C0:10) [15:00:42:189]: MainEngineThread is returning 1603

=== Logging stopped: 5/13/2013 15:00:42 ===

MSI (s) (C0:78) [15:00:42:205]: User policy value 'DisableRollback' is 0

MSI (s) (C0:78) [15:00:42:205]: Machine policy value 'DisableRollback' is 0

MSI (s) (C0:78) [15:00:42:205]: Incrementing counter to disable shutdown. Counter after increment:

 

0

MSI (s) (C0:78) [15:00:42:205]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows

 

\CurrentVersion\Installer\Rollback\Scripts 3: 2

MSI (s) (C0:78) [15:00:42:220]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows

 

\CurrentVersion\Installer\Rollback\Scripts 3: 2

 

OTHER THINGS I HAVE COME ACCROSS AND TRIED WITH NO SUCCESS

 

open cmd as admin enter

reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions /va /f

did not work

Change registy key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem

change NtfsDisable8dot3NameCreation from 2 to 0 didn't help reset back to 2

 

NOTE: I renamed the log directories so I had clean logs each try and found that a good creator install produces

a single file

Repeating that for burn produces files for burn only no new creator logs. Makes seaching logs easier

 

I did find a condition set

when I have Drive G turned on I get the following entry in the burn log

MSI (s) (C0:10) [15:00:26:028]: PROPERTY CHANGE: Adding ROOTDRIVE property. Its value is 'G:\'.

MSI (s) (C0:10) [15:00:26:028]: Transforming table Directory.

 

MSI (s) (C0:10) [15:00:26:028]: PROPERTY CHANGE: Adding CostingComplete property. Its value is '0'.

MSI (s) (C0:10) [15:00:26:043]: Transforming table FeatureComponents.

 

 

when I turn G off I get different entry (I still have a J and K drive running)

Action start 18:14:33: CostInitialize.

MSI (s) (DC:A4) [18:14:33:423]: PROPERTY CHANGE: Adding ROOTDRIVE property. Its value is 'C:\'.

MSI (s) (DC:A4) [18:14:33:424]: Transforming table Directory.

 

MSI (s) (DC:A4) [18:14:33:427]: PROPERTY CHANGE: Adding CostingComplete property. Its value is '0'.

 

Any Help I can get with my problem is appreciated

LogFile 13-05-13 15-00.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...