Jump to content
  • Who's Online   0 Members, 0 Anonymous, 38 Guests (See full list)

    There are no registered users currently online

Question

Hello I hope I'm putting this in the right section if not please move to the right one.

 

Alright my issues is when I double click on the Roxio Game Capture HD PRO nothing happens it shows the little hour glass like it wants to load but doesn't, I've tried right clicking and running it as an Admin but still nothing happens. When I first got my Roxio it wasn't doing this everything was working fine. I could stream, record with audio with the few times it crashed. I've tried doing a Registry clean/fix(said there was nothing wrong) and I have tried using the repair feature that comes with the disk it didn't do anything and when I uninstalled then reinstalled it did not fix the issue.

 

I hope someone can help me out because I do like the Roxio Game Cap.

 

my laptop specs are

 

Processor: Intel® Core™2 Duo Cpu T545 @ 1.66GHz 1.67 GHz

Memory (Ram): 2.00 GB

System type: 32-Bit

 

Windows Vista

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

When it works then stops, it is often a Reg Cleaner (part of your AV) that killed it.

 

You can do a proper repair and it should restore it for now.

 

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Now insert your Roxio Disc - run Install.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

When the Repair competes, turn your AV & Firewall back on and reboot.

 

Check for updates when you start the program.

Share this post


Link to post
Share on other sites
  • 0

Alright I did what you said turned off my Firewall, my Advanced System care, and norton security suite, however it's still did the same thing maybe I did it wrong but I think I didn't any other tips?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×