Jump to content
  • 0

Usb Device Not Recognized


Eaton
 Share

Question

I'm having trouble getting my brand new RGC HD Pro to work. When I plug in the device via USB, the install fails and I get a message "USB device not recognized". In device manager, I see an "unknown device" in the Universial Serial Bus controllers section; in the sound, video and game controllers section, only my sound card is listed.

 

Does anyone have a work around for this? Is there an updated driver out there somewhere? Thanks in advance for your help.

 

Please note:

1. I installed the software BEFORE plugging in the device.

2. I've tried 2 different cables and 3 different USB ports.

3. I've tried to uninstall the device in device manager and then used the install CD to "repair"

4. I've used the install CD to "remove" the sofware and then reinstalled the software (before plugging in the device).

5. The device powers on (purple light) when I attach the USB cable.

6. I can see video and hear audio from my Xbox on my attached TV when the HCG HD Pro is connected.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...