Jump to content
  • 0

Installed Software Then Nothing Please Help! So Frustrated


pansy
 Share

Question

Just got my kid Game Capture for Christmas. I install the software just fine, but when I click on the icon nothing happens. Tried reinstall and nothing happens. I've tried running it several times and nothing happens. What is wrong or am I just SOL with this product?

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Just got my kid Game Capture for Christmas. I install the software just fine, but when I click on the icon nothing happens. Tried reinstall and nothing happens. I've tried running it several times and nothing happens. What is wrong or am I just SOL with this product?

 

You bought the old RGC Device not the new RGC HD Pro Device?

 

Did you install using these guidelines, shutting down all programs especially antivirus / firewall software ?

 

http://corel.force.c...kA060000000L3eQ

 

Did you wait until the software was installed before plunging in the Roxio USB Capture Device?

 

If not windows installed generic drivers that won't work with the device.

 

With the RGC Device plugged in do these two entries show under sound video and game controllers?

 

post-97-0-70874700-1357134107_thumb.jpg

Link to comment
Share on other sites

  • 0

OK. I reinstalled using your suggestions to the best of my abilities. Only one entry for roxio GAMECAP appears under the RGC Device plugged in do these two entries show under sound video and game controllers? Not two enties.

Link to comment
Share on other sites

  • 0

OK. I reinstalled using your suggestions to the best of my abilities. Only one entry for roxio GAMECAP appears under the RGC Device plugged in do these two entries show under sound video and game controllers? Not two enties.

 

I asked you questions and never told you to reinstall at this point!

 

You never answered all my questions, will you now?

 

In Device manager do you show a entry under other devices with the RGC USB Device plugged in?

 

When you reinstalled was the USB Device plugged in or not?

Link to comment
Share on other sites

  • 0

Sorry. Let's see

You bought the old RGC Device not the new RGC HD Pro Device? I bought the old RGC devise

 

Did you install using these guidelines, shutting down all programs especially antivirus / firewall software ? I shut down my ntivirus/firewall. The other suggestion--- I pulled up the links and I think I am OK. But, frnkly I do not know a lot about what I am doing so I am not completely sure,

 

http://corel.force.c...kA060000000L3eQ

 

Did you wait until the software was installed before plunging in the Roxio USB Capture Device? Yes. I left the Roxio USB Capture device unplugged during installation each time

 

If not windows installed generic drivers that won't work with the device.

 

With the RGC Device plugged in do these two entries show under sound video and game controllers? When I plug the RGC device in now only one entry shows not two for Roxio GAMECAP.. Undeer Other Devices it shows an Unknown Device.

 

Thank you for helping me. I do not know what I am doing.

 

I w

Link to comment
Share on other sites

  • 0

With the Roxio Game Capture Device plugged in open device manager and right click uninstall, OK, on the other device entry and the Roxio Gamecap entry under sound video and game controllers.

 

Now unplug the Roxio Game Capture USB Device and reboot the PC. When the PC is up and running put the installation disc in a drive and when the installer offers choose the repair option. When it's done reboot the pc and remove the installation disc. now open device manager and plugin the Roxio Game Capture USB Device and see if the two entries show under sound video and game controllers, and nothing under other devices?

Link to comment
Share on other sites

  • 0

Completed above tasks. Now, there are two entries for Roxio GAMECAP under Other Devices and no Roxio GAMECAP entries under sound, video and game controllers.

 

That is the way it should be and the RGC USB Device drivers are installed correctly.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...