Jump to content
  • 0

No Signal, Not Listed In Device Manager


First I want to thank the digital gurus for thier time in the trenches with a relativley new device. As frustrating as this can be I'm making a post to feed the "obvious factor" that something is wrong with the RGC HD Pro. I too have followed the installation guide, had the software install successfully, connected to a usb 2 and had my laptop fail to recognize it. Having tried about 12 different variations of repairing, uninstalling, driver updates and reinstalling and following all the posts in this topic I am exhausted. The neccesary system info follows, device manager list with expanded sound, video and game controller list. Note* other devices not present.






OS Name Microsoft Windows 7 Home Premium

Version 6.1.7601 Service Pack 1 Build 7601

OS Manufacturer Microsoft Corporation

System Name JACOB-PC

System Manufacturer Dell Inc.

System Model Dell System XPS L502X

System Type x64-based PC

Processor Intel® Core i7-2670QM CPU @ 2.20GHz, 2201 Mhz, 4 Core(s), 8 Logical Processor(s)

BIOS Version/Date Dell Inc. A07, 10/20/2011

Installed Physical Memory (RAM) 8.00 GB

Name NVIDIA GeForce GT 540M

Driver Version


Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Was the RGC HD Pro plugged in to a USB 2.0 port when you took the Device Manager pic?

Share this post

Link to post
Share on other sites
  • 0

What does happen when you plug it in?


Are their sounds? Do the lights come on, on the GameCAP?


Have you tried it on another PC?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now