Jump to content
  • 0

Select Video Device Failed


Prazia
 Share

Question

Pasting this over from the "Game Cap for Consoles" Section because I believe that was the wrong area, anyway, here is the thread.

 

I received the Roxio Game Capture HD Pro for Christmas, and have been having this problem ever since. I've re-installed and repaired the program at least twenty times now, and it still isn't working. My computer specs are completely up to date, and far exceed the minimum requirements for recording game play. I have all of the drivers installed and up to date, and all of the Roxio software updates installed. When I check my devices (under game controllers) only one Roxio Game Capture device displays. What on earth is the problem here?

 

Extremely frustrated that I cannot get this to work. At this rate, I'm never using another Roxio product again, because this is just pathetic. Oh, and I forgot to mention it but all of my cables are connected properly. This is using an Xbox.

 

I just now realized that it is actually a problem that I'm not seeing two Roxio devices. Working on trying to fix this now.

 

 

Edit #2: I also forgot to mention that when I hit "Tools" and select "Options" the program freezes and windows tries to check for a solution to the problem.

 

 

Edit: Yep, still doesn't work even after following these steps to the T:

 

 

With the Roxio USB Device plugged in, right click the unknown device, and click uninstall.

 

Unplug the USB Device from the PC and reboot the PC.

 

When the PC is up and running place the Roxio installation disc in a drive and run repair when it's offered. When it's finished reboot the PC.

 

When the PC is up and running open device manager and plugin the Roxio USB Device and the 2 Roxio Game Cap entries should be there.

Edited by Prazia
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Okay, I am no longer receiving a red "No Signal" message for my device. However, I am now getting the "Select Video Device Failed" error. This is incredibly frustrating, and probably one of the worst pieces of software I've ever used. Ever. I've even restored my system to a point when no Roxio product has touched it, and then I installed the software, once that was done and the computer restarted I plugged in my Game Capture HD Pro, and turned on my Xbox, and I still get this error.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...