Jump to content
  • Who's Online   0 Members, 0 Anonymous, 18 Guests (See full list)

    • There are no registered users currently online
  • 0

Gc Hd Pro Not Working


VestaL
 Share

Question

I hate to be vague in the title (because from what I've seen, people here do nothing but complain about that and rightfully so), so I will try to give as much info as I can on what I've done.

 

Roxio Game Capture Software: Green "No Signal" and all the options are greyed out and unavailable (I can't even change the destination the videos save to)

 

All my cables are plugged in (360 Setup; HDMI from Xbox to Input; HDMI from TV to Output, USB from Roxio GC to PC.) The Roxio GC power light is illuminated which would suggest the USB portion is functioning correctly, and I have tested both HDMI cables by connecting my laptop to my tv and streaming a video, as well as running my 360 on each HDMI. They both work as expected.

 

I have tried restarting my computer (multiple times) as well as uninstalling and re-installing the provided software to no avail. I even tried moving the USB cable from a 3.0 to a 2.0 port on my laptop.

 

I seen in a separate thread that someone had posted a picture from their device manager. When going through mine, the Roxio does not appear in any of the categories, not even as "Unknown."

 

There is also no indication of connection on the Roxio GC itself (HDMI light is not illuminated). And this may sound stupid to mention, but I'm sure it will be asked; Yes, my tv is on the correct HDMI channel.

 

When turning on my xbox I get a blank screen on my TV and no response on the Roxio game capture pro software.

 

Any suggestions would be greatly appreciated. Picture attached to show Roxio software and device manager. The picture was taken with my xbox turned on, as well.

 

post-109349-0-81116100-1357745604_thumb.png

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Either the GameCAP itself is faulty or the USB ports...

 

One thing with Laps is that not all USB ports have the power needed to drive a device like the GameCAP :huh: (My little Dell has 3 USB Ports of which only one has the amps needed!)

 

Two ways to go -

 

Take it back now while you can!

 

Test it out on a PC to at least see if it shows up in Device Manager
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...