Jump to content
  • 0

Worst Software I Have Ever Used


Robm86
 Share

Question

Absolutely useless.

 

I had read reviews before i purchased the HD Pro but thought that all the negative feedback was exaggerated as i used to use the Roxio SD capture card and was really impressed but this version is very poor. Constantly freezing when trying to capture and then when it does decide to capture it just lags and goes horrible. ( i was previously running an HD PVR with no issues so it's not my computer) I was also really looking forward to the built in streaming yet that is 10 times worse.

 

All in all i am very very disappointed with the software and without the software working i can't even see if the capture card is of a good standard or not as i cannot even get a video out of it.

 

I really do hope there is some kind of patch?

Edited by Robm86
Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Most likely your PC or your Install...

 

List your pc specs, like I have in my sig block. Also your Windows Performence Index (Win-Pause) and the Component that has the low score ;)

 

At the same time I think you should do a proper repair, following these steps:

 

Unplug the device and put it aside till later.

 

Turn off your Anti Virus, Firewalls, Registry Cleaners, etc. and insert your Roxio Disc, run Install.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

Then turn your AV & Firewall back on and reboot.

 

So you know, the delay on the preview screen is normal. A read through the FAQs may help you understand what to expect ;)

Link to comment
Share on other sites

  • 0

It always seems to be the PC and not a fault with the program doesn't it? i have no issue with any other software i have ever used on this computer apart from this 1 so i cannot see it being my computer.

 

Also what are the required specs to run this software successfully?

 

I'll do the repair now and see what happens.

Link to comment
Share on other sites

  • 0

Sorry i did not see that you asked for a list of my specs.

 

Urm i am not sure if this is the correct stuff but here goes

 

Acer - Aspire X3810

 

Pentium® Dual-Core CPU E5200 @ 2.50GHz 2.5 Ghz

 

Memory (RAM): 3.00GB

 

System type: 32-bit operating system.

 

Is that all you need?

Edited by Robm86
Link to comment
Share on other sites

  • 0

Thanks!

 

Yours is nearer to the minimum but I would expect it to work but with some slowdowns.

 

The Windows Performance Index (Win-Pause) is some indication of performance... a couple of users here with 3.1 & 3.3 numbers report disappointments.

 

I have it on one PC with 3.4 and see some stuttering and pixels during capture :( On a better PC (5.9) there are no issues.

 

Still it should not crash! That is why I recommended that specific repair process in Post #2.

 

Please try that and see if there is any improvement.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...