Jump to content
  • 0

Usb Not Recognized As Gamecap


Japester36
 Share

Question

My son has a new RGC and is trying to get it installed on his Win 7 laptop.

 

He followed the instructions but this made no mention of installing the software before plugging in the USB cable. Only after coming here is that very apparent!

 

Sadly, this means he has 2 incorrect entries in Device Manager, 'USB Input Device' and 'HID Compliant Device', under Human Interface Devices. Now no matter how many times we have uninstalled them or used Repair on the CD with reboot, we still get them back every time we plug in the RGC USB.

 

I have also deleted all the hidden device entries in Device Manager but still no joy.

 

Any suggestions how I can rectify without reinstalling Win 7. Also, System Restore is not active so we can't just roll back to before the install was first done.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

See if this works for you:

 

ry this:

 

Download the Revo Uninstaller. Then turn off your AV & and any Firewall you are using.

 

Run the Revo Uninstall, in Moderate mode, and uninstall Roxio!

 

Reboot and with the AV & Firewall still off, install Roxio software..... then plug in the Roxio USB

 

Turn on your AV & Firewall and reboot.

 

See if the Device Manager shows the Game Cap in the correct location

Link to comment
Share on other sites

  • 0

Thanks for the helpful advice. I have tried this exactly as described and unfortunately the same 2 USB devices appear in Device Manager.

 

As a double check I have now done the installation on my 1 week old Win7 i7 Laptop and followed instructions to the letter. The same thing has happened on my laptop. I have changed the USB Cable to isolate that and still no joy.

 

Having scoured around I can see people have USB Unknown but not getting it installed as USB Input and HID devices. Is it likely to be a faulty unit?

Link to comment
Share on other sites

  • 0

To just really check, I've now installed to a 3rd machine, XP 32bit, and it has the same results. USB Input Device and HID Compliant Device appear under Human Interface Devices.

 

So that makes Win7 32bit, Win7 64bit and XP 32bit all with the same results.

 

Interestingly, I found a couple of others on this forum with this problem but sadly no resolution http://forums.support.roxio.com/topic/76357-no-source/

 

Any other ideas or am I now looking like I should return for a replacement?

Link to comment
Share on other sites

  • 0

Just to help others, this turned out to be a faulty unit. It was returned to the supplier, they tested and found the same issue.

 

I have received a new one and as soon as it was plugged in it recognized properly with the correct 2 entries in Device Manager. This with the original software setup.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...