Jump to content
  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    • There are no registered users currently online
  • 0

Roxio Media Capture Not Working



Ow wow, im not the only one having this issue, bought a roxio today and again the capture option of the software gives an error you discribed,,


However here is my PC Spec



Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120830-0333)

Language: Dutch (Regional Setting: Dutch)

System Manufacturer: Hewlett-Packard

System Model: p6-2004nl

BIOS: Ver: HOL_718.ROM vHOL7.18

Processor: AMD A8-3800 APU with Radeon HD Graphics (4 CPUs), ~2.4GHz

Memory: 8192MB RAM

Available OS Memory: 8178MB RAM

Page File: 2948MB used, 13407MB available

Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: 96 DPI (100 percent)

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

DxDiag Version: 6.01.7601.17514 32bit Unicode



and im getting a kinda APPCRASH


I've searched the whole day for a solution even the disable firewalls stuff and repair ive found here on the forums but it seems not to work at all.

Im kinda lost now:(

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Even tried this from another post


Unplug the RGC device and put it aside until you are done!


Download the Revo Uninstaller in moderate mode to remove what is there!


Create a new user account with full Administrator privileges.


Reboot and log on with that new account.


Turn off your AV and any Firewall you might have.


Install the RGC Software (device still unplugged!)


Reboot to your regular account, turn on your AV and Firewall and take it for a test drive


But still no success :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...