Jump to content
  • Who's Online   0 Members, 0 Anonymous, 4 Guests (See full list)

    • There are no registered users currently online
  • 0

Dissapointed


michaelsalter92
 Share

Question

Sorry guys but im highly dissapointed at the moment with my roxio capture card. First they said 4-7 days I got it 3 weeks later then I needed the component cables.

 

But yeah even when I got it and its setup they say its windows 8 supported but no way its terrible software. The application crashes on my windows 8 64 bit half of the time, it says broadcasting and when you check in stream the channel sometimes goes offline but its still saying broadcasting the only way to fix is to stop and restart the new stream. Sometimes clicking stop or start crashes application. Sometimes application wont close I have had bugs where its all plugged in and I get signal status ready or smth and its just a black screen. Kind of works with xsplit but you cant mute xsplit sound ( not roxios problem )

You can only stream to twitch.tv if your NOT streaming to twitch TV you cant add a live microphone. Roxio sort it out this is a disgrace. I am still eligible for a refund so I really will and get a REAL capture card with REAL software not half made crappy windows 8 support.

 

Sorry guys just if theres any advice you can give to fix some issues please let me know.

 

BESIDES THIS: The quality is epic.

Edited by michaelsalter92
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Probably not...

 

When the System Requirements say NOT INCLUDED what makes you think that a component cable would be included :huh:

 

You are located in the UK - WHERE did it ship from?

 

It runs fine on Win8, if it is crashing you likely have other issues with your PC that are causing that... Same for the Streaming...

 

You notice that nothing in the advertising states that it will work with Xsplit!

 

Many users have but you are going to have to dig around the Streaming Forum and see what you can find ;)

Link to comment
Share on other sites

  • 0

Probably not...

 

When the System Requirements say NOT INCLUDED what makes you think that a component cable would be included :huh:

 

You are located in the UK - WHERE did it ship from?

 

It runs fine on Win8, if it is crashing you likely have other issues with your PC that are causing that... Same for the Streaming...

 

You notice that nothing in the advertising states that it will work with Xsplit!

 

Many users have but you are going to have to dig around the Streaming Forum and see what you can find ;)

I have tried looking for issues, I just reinstalled updated drivers. im streaming right now if u wanna check bet you after 20 mins it will just go offline it did it about 2 minutes before this post. Even though in roxio still says streaming. I have 60mb internet. So thats not an issue and an i7

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...