Jump to content
  • 0

Red "no Signal" Error



The error I'm getting is a red "No Signal" from the Roxio Gamecap HD Pro capture device to the PC, resulting in not being able to record or stream.


I've been able to use the device to stream on Twitch a couple times last week, Tuesday March 12 and Thursday March 14, using both a Wii U on HDMI connection and a PS3 on Component connection. Yesterday (Saturday March 16), the red No Signal error would not go away.


I ran the Uninstall/Re-install, I ran Repair, I checked to make sure I wasn't missing an update (I'm not), I reset all my connections, unplugged all the cables and re-plugged in all the cables, checked each of my laptop's three USB ports, and nothing has restored it to its working condition from Thursday March 14. Currently, if I go into the software, the device is selectable, but every other option is greyed out - the source, all other options, and quite obviously, the "Live Stream" and "Record" buttons.


Currently, my setup is as follows: I run component source cables from the PS3 as well as HDMI cables from the Wii U and the XBox 360 to the Device (obviously, the Wii U and 360 aren't plugged in at the same time). I run component cables as well as an HDMI cable from the Device to the TV.


I would say it's a problem with the device or the USB cable itself, but while I get no resulting signal to the PC, the image and sound continue through the device to the TV, so I get normal transmission there - and as the USB cable also supplies the power to the device, the device is still powered and connects and still is shown as the source device. I'm just not actually able to ​use​ the device to stream or record. On the earlier days, I was able to use the HDMI and Component connections.


I'd appreciate any assistance you folks can offer me; after having the device work a couple times, I was really amped to start a couple playthrough projects and yesterday was a real disappointment.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts


RetroSpock reports that when the PS3 is switched from HDMI to Component, it will not Stream. Instead it throws a ‘not connected’ error from RGC, despite the fact it is showing in the Preview pane!


Fix it to reboot the PS3. Try that!


However, that fix is only to get the PS3 back on track using Component and it sounds like yours is going a little beyond that...


I think what you want to do is try a repair but make sure you do it this way...



First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.


With the Device Plugged in, go into Device Manager and uninstall it!


Remove the Device and set it aside for later.


Now insert your Roxio Disc - run Install.


Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)


When you reach the screen where
is offered, choose that!


When the Repair competes, turn your AV & Firewall back on and reboot.


Probably a good idea to Print that out ;)


Also, you may have to do it 2 or even 3 times :huh:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...