Jump to content
  • Who's Online   0 Members, 0 Anonymous, 234 Guests (See full list)

    There are no registered users currently online

  • 0
Sign in to follow this  
ngonline

My Roxio Gamecap Hd Pro Wont Work

Question

I just got my Roxio HD PRO yesterday and the thing won't work. I had another one before that worked fine until I broke it lol. But the purple light comes on when I plug it in but the pass-through won't work and a green no signal light comes on. It does not show up in my device manager at all. Here are some screen caps of my device manager and capture window with the RGC plugged in to the computer.

post-109813-0-05654700-1364093418_thumb.png

post-109813-0-06960500-1364093454_thumb.png

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I just got my Roxio GameCap HD PRO yesterday and it won't work. I had another one before but I accidentally broke it lol. But the purple light turns on, but the passthrough doesnt work and a green no signal light comes on. It does not show up at all in the device manager.

Share this post


Link to post
Share on other sites
  • 0

I just got my Roxio GameCap HD PRO yesterday and it won't work. I had another one before but I accidentally broke it lol. But the purple light turns on, but the passthrough doesnt work and a green no signal light comes on. It does not show up at all in the device manager.

Share this post


Link to post
Share on other sites
  • 0

There is no driver present and it will not work, nor will the pass through work without the driver...

 

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Now insert your Roxio Disc.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

When the Repair competes, turn your AV & Firewall back on and reboot.

Share this post


Link to post
Share on other sites
  • 0

I have the same problem, I did everything you said to do and it didnt work, I'm getting very frustrated trying to set the roxio up :/

Share this post


Link to post
Share on other sites
  • 0

I have the same problem, I did everything you said to do and it didnt work, I'm getting very frustrated trying to set the roxio up :/

Start a new Topic With Details... 'mee too' posts are seldom really the same issue ;)

 

EDIT: he did!

Edited by Jim_Hardin

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×