Jump to content
  • Who's Online   0 Members, 0 Anonymous, 4 Guests (See full list)

    • There are no registered users currently online
  • 0

Could Not Open Sound Device!




I have a clean, updated install of Creator 2012 on my Dell T3400 running Windows 7 64-bit (all services packs & patches, latest vid & sound drivers).


I have an Creative Soundblaster X-Fi Platinum w/ the front breakout panel attached. The machine has an Intel core 2 quad running at 2.4 ghz, w/ 8gigs of good RAM. The C: drive is a mirrored pair, but that's not involved as Creator and the scratch/save folders are on the D: drive which is a 750gb drive that's basically empty at this point.


I have the output from my phono pre-amp running to the Auxiliary 2 input on the front of the machine. The sound is working fine, I can hear the LP, I can listen to it on headphones or the 5.1 speakers. However when I try to capture the line in (either from the 'Roxio LP and Tape Assistant' or 'Roxio Easy Audio Capture') I get the #$^@ "Could Not Open Sound Device!"


The 'Capture From:' drop down menu lists 9 different options from the sound card. I have gone into control panel to the 'recording' tab and made sure the 'Show Disabled' and 'Show Disconnected' items are checked. I've tried setting the Aux 2 line to the default w/ no change. I've gone down the list and tried each of the inputs and they all give the same error message. I've tried running Creator 2012 w/ admin rights. I've changed just about ever setting I can find or think of. (I did pc support for a living for 10 years, so I'm reasonably savvy with this stuff).


Creative's suite of bloatware that comes with their driver includes an audio capture utility and that manages to capture the output as a .wav file with no issue, so not sure why Creator is having such issues.


Would appreciate assistance in getting this thing working. It seems this should be one of the simplest things I could ask this software to do!



N Hazel

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

'Roxio LP and Tape Assistant' or 'Roxio Easy Audio Capture')


Do you mean Digitize Lp's and Tapes & Capture Audio From Sound Card?


Don't know, I've used Creative's Capture What You Hear with good results.


When I've 'Capture Audio From Sound Card' I used Roxio USB Capture Device as it shows in the drop down as a capture device.


Did you build the box? Is the front panel connected to the MB correctly? Have you tried connecting to the rear of the sound card?


From, 'Digitize Lp's and Tapes'



Link to comment
Share on other sites

No, I did not build the Dell T3400, it was built by Dell. I'm pretty sure the front panel is connected correctly as the signal from the turntable is coming out of the speakers. Also, Creative's software is able to record the signal. It doesn't seem to matter what which part of Roxio I use (Digitize LPs and Tapes, or Capture Audio from Sound Card), as soon as I select any of the 9 options from the drop down showing my sound card ("what your hear", "Auxiliary 2" etc) it immediately pops up 'Could Not Open Sound Device!' After that attempting to press any of the options will lock up the software.


I've tried inputs on the back of the machine with the same results. It's like it's not really looking for the card or looking at the wrong place. The motherboard on the machine does have an onboard sound but it is turned off in the BIOS and does not show on any of the menus.


I've seen others users of Win 7 64-bit have similar issues but the solutions that fixed them did not make any difference to my machine.


Thanks in advance for any help,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...