Jump to content
  • 0

Missing Mpg2 Codec ?


Dinky
 Share

Question

Hi all,

 

Now, I am really confused.

 

I want to create a bluray containing multiple animation videos. So I drag and drop the video's to Toast 11. They are all VOB's with Mpeg2 codec, except one, which is MKV. Initially I just let Toast do its job, which took more than 24 hours to encode a 5GB MKV and the result was garbage. Probably because the videos are mixed PAL and NTSC. Anyway, I then used Kigo Video Converter to convert the file to PAL with Mpeg2 codec. When I drop the resulting file into Toast, it claims it is missing the MPG2 codec.

 

Now this is very strange, because the VOB's are Mpeg2 too. When I inspect the videos using Videospec, they show up all with the mpeg2 codec, yet Toast is refusing the converted file. Mpeg2 codec is mpeg2 codec, right ? So why accept the other files and reject the converted one ??

 

Who can shed some light here ?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I'm confused, too. Toast has its own built-in MPEG 2 decoder and reader.

 

There may be a better approach to your project. You say you're adding VOBs so that means they are standard definition. I'm presuming the mkv is high definition. You're burning Blu-ray so is it accurate that you want the HD video to remain that way. If you put the VOBs ahead of the MKV in the Toast window it is very possible that Toast encoded it to SD. If the MKV had been first it would have been encoded in HD and the existing SD videos would have remained that way.

 

It may be a nuisance but what I'd do in your case is create disc images for each group of videos that have the same resolution and frame rate rather than mixing the up in one project. Then I'd mount the disc images and add the BDMV folder of each to the Toast window. I believe Toast will locate the .m2ts videos contained in the BDMV folder. If not, you may need to control click on them and choose Show Package Contents to open a Finder window where you can manually drag them into Toast.

 

When you have everything in Toast the way you want go to the Custom Encoder Settings window and choose Never Re-encode. Toast should only do multiplexing rather than encoding when you click the Burn button.

Link to comment
Share on other sites

  • 0

Thanks for your answer. The reason I'm creating a blu-ray is two-fold:

1) keep the Full HD format of the MKV as you said (The VOB's are 720p, so that's HD too)

2) use the 25GB capacity to store multiple movies

 

I did put the MKV in as the first video. I wonder why the order would make any difference, btw, since I would assume Toast will keep HD as HD since I am creating a Blu-ray project.

 

I will do a test where I will take out the NTSC file and see if that will make any difference. The problem is, encoding in Toast is such a lengthy process. I mean, come on, more than 24 hours for a 5GB file is ridiculous. So what I would like to do is encode to a format Toast will accept and not re-encode and do the encoding using another program like Handbrake. I figured MPEG-2 would be the right choice, because the VOB's are Mpeg-2 and are not re-encoded by Toast. That is where problem #2 comes up: Toast does not recognize the Mpeg-2 used by Handbrake. I can use Mpeg-4, but then Toast will start its never ending re-encoding. It looks like I'm stuck between a rock and a hard place.

 

I hate all these different formats, especially if they appear not to be standard. It looks like there are multiple flavors of Mpeg-2 around. The advantage of having a standard is there are so many of them.....

Link to comment
Share on other sites

  • 0

I don't know if the order makes any difference with multiple-resolution videos, but I know it was an issue with some slide shows so I thought I'd toss that in to the mix.

 

There is a custom encoder settings window. Click the Custom button and then the Encoding tab in the window that appears. There you'll see you can choose either MPEG-4 or MPEG-2 encoding or the Blu-ray video. You also can choose Never Re-encode. In your case I'd choose MPEG-2 and Never re-encode. Toast still will encode any video that it determines is not meeting the Blu-ray specs, but it will only multiplex others which goes very fast.

 

As for VOBs, Toast prefers those to be in a VIDEO_TS folder and accessed via the DVD tab in the Videos section of the Toast Media Browser. The VIDEO_TS folder needs to be placed on the Desktop or in the Movies folder for Toast to find it in the Media Browser.

 

Be sure to change the default setting for when the Converted Items folder is cleared. That's where Toast writes the encoded video and audio streams that it later uses when authoring a disc image or writing to disc. If anything goes wrong with a stage after a video is encoded you may be able to simply drag the video from the Roxio Converted Items folder back into a new project in the Toast window and Toast will only need to multiplex the next time.

 

I don't know what would cause Toast not to recognize an Mpeg-2 file created by Handbrake. If it is in a VOB container maybe you should open that in MPEG Streamclip and choose Save as MPEG to get it out of the VOB. As I mentioned, Toast doesn't like VOBs very much.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...