Jump to content
  • Who's Online   0 Members, 0 Anonymous, 8 Guests (See full list)

    • There are no registered users currently online
  • 0

IAM5500
 Share

Question

I have been using my Game Cap HD for a while now and only had one issue with it until now. I have plugged all the HDMI cables and the USB in correctly. However there is no display on my TV. I opened up the capture software and i can see the xbox dashboard and everything. It says ready to capture. There is just no display on my TV. If anyone has a solution to this that would great!

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I have been using the Game Cap Hd for a while now and I never had this problem. I recently plugged in all the cords in the correct places and to my surprise nothing was showing up on the TV. I opened the software and it shows the Xbox dashboard and the status says ready. I'm quite confused because this has never happened to me before. I tried switching the HDMI cables around and nothing seems to work. Does anybody konw what might be the issue here?

Link to comment
Share on other sites

  • 0

Jim

 

I just merged his 2 posts.......when I did this the 1st one appeared.

:lol: I did that just so I could used the Topic Solved button to see the first post... Then I deleted mine. We must have been tinkering with them at the same time... lucky the internet didn't explode :huh:

 

IAM5500: you seem to indicate that everything was working before but Now you get no signal on your TV???

 

Is that correct? ~ if so, try another TV or device that can accept HDMI input (I want to see if the HDMI Output on the RGC Device has failed ;))

Link to comment
Share on other sites

  • 0

:lol: I did that just so I could used the Topic Solved button to see the first post... Then I deleted mine. We must have been tinkering with them at the same time... lucky the internet didn't explode :huh:

 

IAM5500: you seem to indicate that everything was working before but Now you get no signal on your TV???

 

Is that correct? ~ if so, try another TV or device that can accept HDMI input (I want to see if the HDMI Output on the RGC Device has failed ;))

 

I got another TV from my house and tried to plug it in. The profile select has come up on the TV but is glitching out, It seems to be looping the first 2 seconds from the characters coming up on the screen.

Link to comment
Share on other sites

  • 0

Switch the HDMI plugs at the RGC Device...

 

Try running Xbox to the "Output" and the TV from the "INPUT" (probably won't matter but worth a shot ;))

 

Only other option for you would be Component to the TV, as I am guessing that you are way past the 30 day warranty :huh:

 

You Could try an HDMI to DVI-D adapter (assumes your TV will accept one) BUT those have proven pretty much a hit of miss item...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...