Jump to content
  • Who's Online   0 Members, 0 Anonymous, 35 Guests (See full list)

    There are no registered users currently online

  • 0
Sign in to follow this  
Sazard

Not Working

Question

Hi there forum members,

I recently purchased my Roxio Game Capture HD Pro from Best Buy. I have installed everything and tryed reinstalling and my problem will not fix. I have everything setup correct and I need help.

 

Problems *

When I go to the program's hub I can only go to the edit & share section, not the capture section where I need to go.

Farther details can be explained if you comment, please help me and happy gaming!

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

What happens when you click Capture :huh:

 

First order of business would be a proper repair...

 

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Now insert your Roxio Disc.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

When the Repair competes, turn your AV & Firewall back on and reboot.

 

Skip NOTHING! do each and every step ;)

Share this post


Link to post
Share on other sites
  • 0

What happens when you click Capture :huh:

 

First order of business would be a proper repair...

 

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Now insert your Roxio Disc.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

When the Repair competes, turn your AV & Firewall back on and reboot.

 

Skip NOTHING! do each and every step ;)

Does not work, when I click on it the first time it waits and then when I click on it it just flashes the orange loading thing once.

Share this post


Link to post
Share on other sites
  • 0

 

Hi there forum members,

I recently purchased my Roxio Game Capture HD Pro from Best Buy. I have installed everything and tryed reinstalling and my problem will not fix. I have everything setup correct and I need help.

 

Problems *

When I go to the program's hub I can only go to the edit & share section, not the capture section where I need to go.

Farther details can be explained if you comment, please help me and happy gaming!

Share this post


Link to post
Share on other sites
  • 0

STOP POSTING the same thing all over the board!

 

I can only offer one more solution and that's it!

 

This is extensive, but it what I suggest... Best to print a copy so you can use it to check off each item as you go.

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Download and install the
Uninstaller. Then run it in
Moderate Mode
to remove any traces of Roxio.

 

Create a New User Account with Administrator Privileges.

 

Turn OFF any A/V & Firewall.

 

Reboot and log on to that new account.

 

Copy your entire disc to a new folder on your HDD.

 

In that new folder, right click on Setup.exe and select Properties.

 

Under the Compatibility tab, make sure
nothing
is checked!

 

Right click Setup.exe and select Open.

 

Allow it to Check for Updates (this is for Roxio not Windows)

 

Use the Default Locations!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×