Jump to content
  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • 0

Play And Record On The Same Pc (Aka Passthrough Really Isn't It)


macco
 Share

Question

Hello,

 

I've just received my GameCap HD Pro and went straight for a test with my laptop. In fact, according to the faq (and the only reason I'd bought the thing)

 

3ijl.png

 

Unfortunately, when I try this setup the output resolution of the "passthrough" output hdmi can only be set to a handful of resolutions, none of which matches my monitor (1680x1050). So I'm wondering, is there any fix for this or I can as well sell my game capture and go for something else?

 

To be clear, my connections are as follows

 

laptop hdmi -> roxio hdmi input -> roxio hdmi output -> monitor hdmi input

 

And the roxio is connected to the laptop with the provided usb of course.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

OK a couple things up front...

 

So with your setup, you are using your Laptop to Play the game and run the RGC Device.

 

You will most likely not be able to Capture using the same Laptop to Play and Capture with. (some say they can but Most say it does not work)

 

You cannot 'set the output resolution'!

 

Pass Through is just what it says it is and can only mimic what it receives from your laptop...

 

One thing I have seen in other discussion groups is to make sure you have your laptop's HDMI port set to EXTEND rather than Projector.

Link to comment
Share on other sites

  • 0

Well, the faq stated so, I bought the device just for this reason, so you'd understand my disappontment...

Anyway, what I'd like to do is to be able to chose from more resolution options (in the windows screen resolution settings page) when using the GCHD with passthrough. Right now I can only choose 720p, 1080p and something in between the two. Of course, the rendering on the monitor is terrible, being a 16:10 rather than a 16:9. I supposed the GCHD would only record whatever was input to it and then let it pass through (hence my annoyance) not touched, e.g. setting the resolution at 1680x1050 on my laptop card would let the signal pass unaffected to the screen, as is the case when directly connecting the hdmi to my monitor.

Also, the GCHD is recognized as a monitor itself by windows, so I'm very tempted to consider it just a driver issue, and I hope Roxio would decide to implement more options in a subsequent update (if ever).

 

EDIT: ok so I managed to somehow fit all the pieces in. I'm adding a brief tutorial here for future references (I'll probably add a video later too).

First of all, simply using the passthrough feature seems to be of no use. The graphic card gives you a bunch of resolution supported by the "DEMO TDA19978" monitor, which is actually the GCHD, none of which matched my monitor a/r (16:10). So I:

  • connected the graphic card's DVI ouput to the monitor;
  • set the monitor's input to DVI;
  • connected the graphic card's HDMI output to the GCHD Pro input;
  • in Windows' screen settings chose to duplicate the desktop on <my monitor> and <DEMO TDA19978> (if you don't know which is which try "Identify");
  • chose a resolution that matched my monitor's native one (e.g. mine was 1680x1050);
  • in the AMD Catalyst Control Center went to "My digital flat panels" -> "Properties", then unchecked "Enable gpu scaling" on the DEMO TDA19978 monitor and selected "Maintain aspect ratio" as the scaling option. This second part may not be necessary if your monitor's resolution a/r is 16/9. I was getting stretched recordings since the HDMI output was being forced to the 16:10 a/r.

I still have to grasp the details of why enabling gpu scaling also on the GCHD completely screw the monitor output, but for the moment I'm content. Yet, I'd expected a little more support from Roxio, not everyone's gone mad for this Full HD crazyness.

Edited by macco
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...