Jump to content
  • 0

Roxio Game Capture Problem


Anthon
 Share

Question

After constantly restarting the PC in pursuit of the software, it turns out my capture card is the one feeling under the weather. When I plug it into the PC with USB, the Component signal is on. The problem is that there's nothing plugged into the HD Pro and the signal still comes on every time I plug it in. Also, the software was working after so many restarts and then when I plug the HD Pro in, the "Media Import" software crashes after loading. Any and all help will be appreciated.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

First, "c" comes before "h" so of course it defaults to Component when Nothing else is hooked up! And that means absolutly nothing...

 

It has otherwise been working OK since August???

 

If that is true and you are not leaving anything out, you are just in need of a proper repair :)

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Download and install the
Uninstaller. Then run it in
Moderate Mode
to remove any traces of Roxio.

 

Then turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Now insert your Roxio Disc.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When the Install competes, turn your AV & Firewall back on and reboot.

Link to comment
Share on other sites

  • 0

First, "c" comes before "h" so of course it defaults to Component when Nothing else is hooked up! And that means absolutly nothing...

 

It has otherwise been working OK since August???

 

If that is true and you are not leaving anything out, you are just in need of a proper repair :)

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Download and install the
Uninstaller. Then run it in
Moderate Mode
to remove any traces of Roxio.

 

Then turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Now insert your Roxio Disc.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When the Install competes, turn your AV & Firewall back on and reboot.

Thanks. It's working now! :D

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...