Jump to content
  • 0

Disc Can't Be Read After Being Burned


Diables Bleu
 Share

Question

I just upgraded from Roxio 2010 (worked great, not sure why I upgraded) to NXT Pro 2. I have tried to burn 4 Data DVDs and the process appears to work great. All the files are copied and the disc (DVD+R) is written to. But the disc is unreadable on any of my computers. I have even tried to "finalize" the disc (which I never had to do with Roxio 2010) but the Roxio doesn't even recognize the disc it just burned. Any suggestions?

Edited by Diables Bleu
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...