Jump to content
  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • 0

Gamecap Hd Pro Not Working Properly.



I've been using it for a short time without any problems, then halfway through a recording session, the program froze

Since then whenever I have the device plugged in to the usb port non of the options or buttons show in the recording software

(like this)



When it isn't plugged in or is unplugged all the buttons reappear as such

6ZZ9yY8.pngNo Idea what the %02d %02d %02d means.



I can't re-install or repair the software either as I had to borrow an external CD drive to install it in the first place (unless their is anywhere I can redownload the installation software from from)


Any help would be appreciated -



Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Turned off my firewall and antivirus software, used repair but it made no difference.

I uninstalled and re-installed the program again, but still no change.


Furthermore When I click any of the icons at the bottom, this error message appears before the whole program crashes.


Link to comment
Share on other sites

Open your Device Manager and then plug in the RGC Device.


You Should See 1 entire in Sound and nothing else:




IF anything else shows up, anywhere else (plug and un-plug the RGC Device a few times to make sure) then it must be Deleted and the Repair run again!


Windows Media Player 11 MUST be installed on the PC. (since it worked before I did not consider this)


We have seen cases where it takes 2 or even 3 attempts at Repair for it to work :huh:


Of couse NO tweaks to your CPU or GPU (as gamers are inclided to do ;)) - They Must be set to thier Default Settings!!!

Link to comment
Share on other sites

Ok I threw this thing in a draw nearly a year ago giving up on it, I was hoping whatever my problem was would have been patched by now but I'm still having the same issue with it.





Yes that is the only thing that shows up when it is plugged in, I've tried installing and uninstalling it about 30 more times, still makes no difference, I am still getting the "no signal" and "record time %02d:%02d:%02d"



I am going crazy, I am doing nothing wrong but it has only ever worked a couple of times.

Link to comment
Share on other sites

NO Choice here, you must do a proper repair, so start borrowing a CD Player...


Plan B ~ Get someone to copy your CD onto a Thumbdrive/SD Card (get a little creative) and use that ;)


Proper Repair:


First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.


Unplug your RGC Device and put it aside until you are completely finished.


Now insert your Roxio Disc.


Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)


When you reach the screen where
is offered, choose that!


When the Repair competes, turn your AV & Firewall back on and reboot.


FYI: It is far easier to post pictures here than going through a posting site: Info HERE ;)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...