Jump to content
  • Who's Online   0 Members, 0 Anonymous, 16 Guests (See full list)

    There are no registered users currently online

  • 0
Sign in to follow this  
CinemaPhile

Visual C++ Runtime Error In Roxio Creator 2012

Question

See attached "screen scrape" files for details of erros, environment, etc.

 

Frustrating! It worked fine for a day or so as I was making b/u copies of DVDs, then this. I get a runtime error during disk copy in the Copy and Convert Video sub program. I copied 15 DVDs, then the problem occurred. Once the problem occurs, I have to go into Windows Task Manager to kill the processes:

  • Roxio Burn.exe,
  • RoxioBurnLauncher.exe, and
  • RoxioCentralFx.exe;

and start over again with the same result since yesterday afternoon, and it's 10:00 PM EST in the U.S. Sometimes "sledgehammering" the procs doesn't work either, so there's something hanging around that I can't find, so I reboot. I've tried both a warm and a cold system start, but while I might get Roxio and the Copy and Convert sub proc to launch again, the problem persists. A cold start usually fixes all problems; but this time, something serious is happening, and I'm at a loss.

 

I tried to repair installation in Control Panel; the installer abends because it can't find the package named rcprod.msi and is looking for it in:

 

C:\Users\TrainerNJ\AppData\Local\Temp\RoxioCreator2012_JX90AXD0R13\ROXIOCENTRAL_6X\ . Oddly, it gives me a Setup Wizard Completed Successfully message when it's done; go figure.

 

Neither the package nor the location exists anywhere on my computer; one copy of my software backup CD [created from the download] is bad, and the other [the copy of the copy] has only the privious version of Roxio. The system is generally solid; the physical drives are good, and I've got a RAID 1 configuration, so I sometimes wonder if the location ever existed, but I'll take Roxio at their word.

 

I haven't contacted support for this. Their first response is to come here or to upgrade; so here I am. They were unable to fix a previous problem I had, and as I'm no longer in a warantee period, I'm disinclined to pay for a bug fix if that's what it is; though even I'll admit that's not likely - it worked for awhile. This verson of Roxio is it for as long as I can keep it working, and then I will look at other software options. In the meantime, anybody's input is appreciated.

 

Some notes;

 

I haven't "played" with Roxio for awhile; I find the product's behavior unpredictable. Do others have the same experience?

 

For completeness; I'm running Vista 64 bit; SP1 with current updates except SP2. Please don't suggest I need Vista SP2; I've tried it. The installation completes "successfully", but nothing happens. A MS release note I found on the problem and tried doesn't seem to help. I can't upgrade to Windows 7; my system fails some kind of compatibility check though I bought the box with Vista installed and a Windows 7 CD, and now Windows 8 is available anyway, and by the time I get around to it, Windows 9 will be available if not already. I don't have the time just now to find the problem myself, and I can't afford to be without a machine if I send the box out for repair. I don't want to go down a rat hole fixing this problem; so if anybody has a quick fix [other than buy new,] I'm all ears.

 

post-85065-0-95255900-1391651138_thumb.jpg

post-208-0-06607400-1391657191_thumb.jpg

post-85065-0-06825900-1391652927_thumb.jpg

post-85065-0-09873800-1391653586_thumb.jpg

post-85065-0-35466600-1391653593_thumb.jpg

post-85065-0-99975800-1391651298_thumb.jpg

 

 

 

 

 

edit: CD key redacted

Edited by Brendon

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi,

 

If you look at this topic http://forums.support.roxio.com/topic/77850-2012-install-fails-ms-visual-c-error/ in post #13, Roxio Staff member Sonic Boom said

 

Still unable to reproduce this however I've gotten a user response that uninstalling all VC++ 2008 redistributables and installing latest SP1 redistributable has fixed this.

 

Can be found here:http://www.microsoft.com/download/en/details.aspx?id=5582

 

 

It might be worth a try if nobody comes up with anything better.

Share this post


Link to post
Share on other sites
  • 0

I don't recall if Creator 2012 required Vista to have SP2???

 

The current NXT versions do.

 

It doesn't, at least I don't think so; I was just covering all bases in my question when I included it in my original post.

 

BTW, I find the software in generally unstable. Is this the nature of optical drives or is it Roxio? [This may be the wrong forum to ask that question.] I often have program or system hang conditions. It's such a nuisence that I avoid "playing" with my video library anymore unless it's necdessary.

 

Vista was a poor follow on to XP, but it's pretty solid now. I've got plenty of disk space - 400gb free defragmented space on each volume, and I've got 6g of RAM. Is it the nature of the beast or is there something with my platform I need to look at.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the input, gents. None of the suggestions worked, but a switch to another optical drive worked.

 

I have a RW Blu-Ray drive in my machine as well as well as another RW drive. In the past never had a problem using the Blu-Ray drive, but all of a sudden did [and that prompted my original post.] I tried the other drive, and the sofware is working like a champ.

 

I don't know what allowed me to do 10-15 videos before the problem surfaced, but Roxio is doing what I bought it for, and I won't argue with success.

 

I'm back to creating disk copies of videos currently on my hard drives [for extra backup I'm a belts and suspenders guy.] and I'll fuss with the interoperability of Roxio and my Blu Ray drive some day when I've got a chunk of spare time.

 

Thanks again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×