Jump to content
  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • 0

Setting Roxio Sound Editor As My Default Audio Application Program?



I am trying to set Roxio Sound Editor (Roxio Pro 2012) as my default audio sound program, but I seem to be unable to do so? At the moment to open audio with RSE I have to open RSE, go to File, Add Audio File, and select the file from there (or press CTRL+T). I'd like to be able to double click any audio file I have and have it immediately open in RSE. I was able to do this with Roxio 2011 but this feature seems to have gone?


Right clicking a file and attempting to select RSE as the default program [Program Files (x86)/Roxio 2012/Audio Core/SoundEdit13.exe OR RxQSoundEdit13.exe)] doesn't work. I select this program as the default but after clicking 'OK' no audio file opens and I seem to be unable to change this. Is there any way to set RSE as my default audio program from within the program itself? Or at all?


Thanks for all the help.


Running Win 7.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts



I'm running C2012 in Windows 7 Ultimate. This works on my system:


-right-click the file, go to Open With >Choose default program I'm doing it with a WMA file here.




-Browse to the editor.




Choose the full editor, not the Quick Sound Editor




-make sure the RSE is highlighted, and the "Always use . . ." box is checked




Click OK. The RSE will come up with my WMA loaded already.




Now, whenever I double-click a WMA file the RSE will come up with the WMA loaded and ready. I did this with MP3 and WAV files a few minutes ago and it works there too. [Must remember to go restore them all to original]


That's the way it should work, and the way it does work with Creator 2012 on my machine so it's not a design change to Creator 2012. Is it possible you missed a step or the checkbox?


Note: I haven't been able to check it in a 64-bit Windows 7 like yours, since I have only 32-bit on this machine.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...