Jump to content
  • Who's Online   0 Members, 0 Anonymous, 12 Guests (See full list)

    • There are no registered users currently online
  • 0

Bug With Entering Isrc Code?



I can't figure out how to enter my ISRC code.

The instructions say to enter 2 letters for country, 3 letters for owner, 2 digits for year, 5 digits for serial number. That makes sense -- except that my owner code is a letter, a number, and a letter. Does Roxio actually insist on 3 letters? I've used my letter-number-letter code with Roxio's Windows-based software for years before switching to mac.


I've tried both of these variations: USX9X1450000 and US-X9X-14-50000 (no, X9X is not my actual owner code, but that's the format) and neither works.


Is this a Toast bug or am I missing something obvious?



Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Thanks! Using QM worked. I'm a bit surprised I didn't hear about this change. Yes, I'm a small operator -- but I do pay the RIAA annual fees to be able to issue ISRC codes, and the last I heard from them was that my US prefix was good through Sept. 2014.


I'll write & ask them about it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...