Jump to content
  • 0
Sign in to follow this  
Rickytoons

Could Not Open Sound Device!

Question

I have just replaced my pc and the new one has an onboard soundcard (list as HD Audio device). I have reinstalled Roxio Creator 2012. I am trying to record off the soundcard to digitize old records and have done so in the past with no issue. Now, I have my turntable connected to a preamp and that output goes directly to my Line In on the soundcard. I can hear music through the system, but when I bring up the "Capture Audio From Soundcard" option, I select the Line in option, I get "Could not open sound device!". I checked the options for the sound card and I know its plugged in correctly as I am hearing sound. Is this possibly a Win7 64 bit issue? I was previously on Win7 32-bit with a SoundBlaster sound card. I am tempted to go the Roxio Creator NXT 2 or NXT 2 Pro, but I don't want to spend more money if this is easily correctable.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I found the problem. In the control panel under sound, I didn't have the Line In set as the default device. It was there in my Creative list of devices, but as soon as I made it the default I was able to see the record meters work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×