Jump to content
  • 0
freefallillusion1

Aaaaarrrrgh! Can't Trim In Videowave!

Question

Hopefully I'm posting this in the correct section where some knowledgable person can help! I have Roxio creator premiere and when I opened videowave for the first time, I was thrilled to see that it has a ton of features that my ancient version of videowave didn't. HOWEVER- I tried to trim a clip and it simply doesn't work. I did a search and saw that someone else from 2011 had the same problem but it doesn't look like they ever got it resolved- and they were able to trim everything except mpeg. I can't trim anything! When I open the "trim" window, I can't do anything- the play button does nothing, the sliders move but jump back to start or finish, etc. This is absolutely maddening- I am SO tired of hearing techs say "it works better if..."- am I alone in that I just want it to WORK? OK, rant over... seriously, I would be forever grateful if someone could help! Thank you!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hopefully I'm posting this in the correct section where some knowledgable person can help! I have Roxio creator premiere and when I opened videowave for the first time, I was thrilled to see that it has a ton of features that my ancient version of videowave didn't. HOWEVER- I tried to trim a clip and it simply doesn't work. I did a search and saw that someone else from 2011 had the same problem but it doesn't look like they ever got it resolved- and they were able to trim everything except mpeg. I can't trim anything! When I open the "trim" window, I can't do anything- the play button does nothing, the sliders move but jump back to start or finish, etc. This is absolutely maddening- I am SO tired of hearing techs say "it works better if..."- am I alone in that I just want it to WORK? OK, rant over... seriously, I would be forever grateful if someone could help! Thank you!

 

What program do you have? You posted in the C2012 forum but state you have Roxio Creator Premier which of course is ancient.

 

What operating system do you have?

 

Trim works in all versions (also mpeg of course) from EMC 7 (or earlier) to the current NXT 2

Share this post


Link to post
Share on other sites
  • 0

What program do you have? You posted in the C2012 forum but state you have Roxio Creator Premier which of course is ancient.

 

What operating system do you have?

 

Trim works in all versions (also mpeg of course) from EMC 7 (or earlier) to the current NXT 2

 

Yep, it's Roxio Creator Premiere with Videowave 10 (couldn't find a forum for that), and my system is Windows 7.

Share this post


Link to post
Share on other sites
  • 0

Yep, it's Roxio Creator Premiere with Videowave 10 (couldn't find a forum for that), and my system is Windows 7.

 

That program is not compatible with Windows 7

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×