Jump to content
  • 0
DaveKinetic

No Tv Output

Question

Can anyone help please?

 

I purchased my new RGC HD Pro yesterday, installed the software and then followed the instructions on how to set everything up.

 

At first I couldn't get any picture to my TV, and then after unplugging the USB a few times, it magically appeared for approx 2 mins before disappearing again.

 

Since then I've spent the best part of 3 hours trying to get it to work again without any luck.

 

I've tried 4 different HDMI cables in different combinations, all of which work when connecting my 360 directly to the TV.

 

My computer is way above the minimum specs, and the software appears to be working fine. I get the 360 footage appearing on the PC and it records in really good quality.

 

I've tried a second PC, a 2nd Xbox 360, an Xbox One and another TV (both TVs are HDCP compatible).

 

I know it worked originally for a short time, so everything I have is fine. I'm wondering if maybe the actual unit could be faulty?

 

Thanks in advance.

 

Dave

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

With what you've said, I'd also suggest trying a different USB cable, and or a different USB port on your PC. If you're using a front-panel USB port, try one on the back.

Share this post


Link to post
Share on other sites
  • 0

The Pass Through on the RGC Device has to be attached to the PC with the Software (drivers) installed in order to work!

 

It also adds HDCP coding and some TV's are not compliant...

 

Does the picture show in the Preview window in the Capture Software?

 

Is there a 'No Signal' showing there? If so, what Color?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×